Page tree
Skip to end of metadata
Go to start of metadata

You are viewing an old version of this page. View the current version.

Compare with Current View Page History

« Previous Version 28 Next »

Install supported ROS-2 distribution

By clicking the image,  you can go to the installation procedure of the respective ROS distro.

Note

Rolling distro, is specific for the developers and there are chances to find code that breaks your process. Using Rolling distro is encouraged, only if you are developing a package based on this simulation, else use other distros. 

Create workspace

ROS-2 does not use catkin for building the package unlike ROS-1, rather it uses ament_cmake as the default!

Follow this link to create a colcon workspace https://docs.ros.org/en/foxy/Tutorials/Colcon-Tutorial.html

Before continuing with this tutorial, make sure you have sourced your corresponding ROS-Distro

Automated workspace setup

  1. Download this file to your directory where you want to setup your workspace (usually the /home/$USER)

    Setup script for neo_simulation

    Download the setup script here: setup-2.sh

  2. Make the downloaded file as an executable using:

    chmod +x /setup-2.sh
  3. Just run the downloaded script from that particular directory to install all our packages:

    ./setup-2.sh

Manual workspace setup

Clone neo_simulation2 into your workspace

cd your_colcon_workspace/src
git clone https://github.com/neobotix/neo_simulation2.git

Build workspace

cd ..
colcon build --symlink-install

Sourcing the workspace

echo "source your_colcon_workspace/install/setup.bash" >> ~/.bashrc

Install the relevant ROS-2 Gazebo Packages

sudo apt-get install ros-foxy-gazebo-ros ros-foxy-gazebo-plugins ros-foxy-gazebo-ros-pkgs

Install the ROS-2 Navigation Packages

sudo apt install ros-foxy-navigation2 ros-foxy-nav2-bringup

Clone the neo_local_planner and build it

cd to_your_workspace/src
git clone https://github.com/neobotix/neo_local_planner2.git
cd ..
colcon build --symlink-install

Install the ROS-2 SLAM Toolbox

sudo apt install ros-foxy-slam-toolbox
  • No labels